版面规则
提问时请注意:尽量详细描述操作过程、AVS脚本内容等,最好能写出片名,只贴图有时无法看出问题原因。
提示:发布原创内容请尽量使用附件上传。使用网盘会出现过期失效的问题,请注意。
digimoon
帖子: 49
注册时间: 2011-07-15 11:59

[解决] 使用lsmashsource导入后发现颜色异常

2019-02-21 2:49

转用ffms2,设置colorspace="RGB24"解决了

==========================================
用obs录了一个这样的视频
General
Complete name : C:\Users\Moon\Videos\demo.mp4
Format : MPEG-4
Format profile : Base Media
Codec ID : isom (isom/iso2/avc1/mp41)
File size : 8.37 MiB
Duration : 8 s 159 ms
Overall bit rate mode : Variable
Overall bit rate : 8 607 kb/s
Writing application : Lavf58.20.100

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High 4:4:4 Predictive@L4.2
Format settings : 2 Ref Frames
Format settings, CABAC : No
Format settings, ReFrames : 2 frames
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 8 s 159 ms
Bit rate mode : Variable
Bit rate : 8 602 kb/s
Maximum bit rate : 40.0 Mb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 59.940 (60000/1001) FPS
Color space : YUV
Chroma subsampling : 4:4:4
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.069
Stream size : 8.37 MiB (100%)
Language : English
Color range : Full
Matrix coefficients : BT.709
Codec configuration box : avcC


然后我简单创建了一个avs后virtualdub打开,发现颜色(亮度?)不正常

代码: 全选

LWLibavVideoSource("demo.mp4",cache=false)

用ffplay和chrome打开后看到的正常结果
图片

avs打开看到的却是这样的,初音图标很明显
看着像是color range的问题,但是lsmashsource又没有相关设置,不知道应该如何处理?
图片

qusseei
帖子: 1
注册时间: 2016-03-30 14:40

Re: [解决] 使用lsmashsource导入后发现颜色异常

2019-06-11 19:56

mp4 用LibavSMASHSource,一般LWLibavSource是用给mkv m2ts的吧

详见wiki http://avisynth.nl/index.php/LSMASHSource

回到 “AviSynth”